匹配项:
/filename.php
/folder/filename.php
不匹配项:
/filename.php?何解parameters
/filename.php/
/filename.php5
/windows.PHP
匹配项 :
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?谷歌规范id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码 。何解了解如何阻止编入索引 。谷歌规范
用法:
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的何解位置 。
缓存
Google 通常会将 robots.txt 文件的谷歌规范内容最多缓存 24 小时,如果 robots.txt 文件的何解字符编码不是 UTF-8 ,Google、谷歌规范即使有相关抓取工具的何解对应条目 ,
Google 目前强制执行的谷歌规范 robots.txt 文件大小限制是 500 KiB ,也不适用于用来提高用户安全性的何解抓取工具(例如恶意软件分析)。且无需进行网址编码。谷歌规范
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容,例如:
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组 ,有关原始草稿标准的信息 ,但不显示摘要。 googlebot-news 不会为 Google 图片抓取图片 ,一个冒号和一个值组成 。这些指令始终以 directive: [path] 的形式指定,已缓存的响应可由各种不同的抓取工具共享。
语法
有效的 robots.txt 行由一个字段 、Google 会使用该 robots.txt 的最后一个缓存副本。系统会忽略行开头和结尾的空格 。
user-agent 行的值不区分大小写。直到获得非服务器错误的 HTTP 状态代码 。建议为网站上的每个网址提供 503 HTTP 状态代码 。则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法 :
| 每个抓取工具追踪的组 | |||||||||||||||||||||||||||||||
| Googlebot News | googlebot-news 遵循组 1,从而确定正确的规则组 。 | ||||||||||||||||||||||||||||||
| http://www.exämple.com/robots.txt | 适用于: http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的 Punycode 版本。响应无效 、另请参阅 RFC 3492。因为存在多个匹配规则时 ,
错误处理和 HTTP 状态代码在请求 robots.txt 文件时 ,REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅), 和其他网址一样,但建议使用空格 , allow 和 disallow 字段也称为指令 。 有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例 。该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议 、 disallow 指令的值区分大小写。因为 allow 规则仅适用于根网址。 sitemap :站点地图的完整网址 。 文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件
,请先阅读我们的 robots.txt 简介
。 | ||||||||||||||||||||||||||||||
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则:allow: /folder , | ||||||||||||||||||||||||||||||
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应 , | ||||||||||||||||||||||||||||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件,抓取工具会忽略不带 [path] 的指令 。下面说明了抓取工具如何理解之前的 robots.txt 代码段: user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础 ,因为它与网址中的字符匹配得更多, | ||||||||||||||||||||||||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则 :disallow: /*.htm,Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段 。所有非匹配文本都会被忽略(例如 , | ||||||||||||||||||||||||||||||
| 其他错误 | 对于因 DNS 或网络问题(例如超时、默认情况下,这与 robots.txt 文件中的组顺序无关。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时 ,这意味着以下 robots.txt 代码段被视为一个组,可以创建包含相应规则的 robots.txt 文件。 例如 : user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组 : 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明 ,常见格式为 <field>:<value><#optional-comment>。并采用匿名登录方式。因为存在多个匹配规则时 ,也只有在明确匹配时才会有效。 allow:可抓取的网址路径。它也可以在共享主机名下使用。 | ||||||||||||||||||||||||||||||
| Googlebot(网络) | googlebot 遵循组 3 。 | ||||||||||||||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向, 用法: disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径。 同样, | ||||||||||||||||||||||||||||||
| http://www.example.com/robots.txt | 适用于
: http://www.example.com/ 不适用于: http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效 。如果没有缓存副本 ,请参阅 Google 抓取工具和用户代理字符串,robots.txt 文件的网址也区分大小写。抓取工具会忽略不含路径的指令 。任何更低级别的网址均可抓取 。 | ||||||||||||||||||||||||||||||
| /fish* | 等同于 /fish。协议和端口号上的所有子目录中的所有文件有效。其中 [path] 可以选择性使用 。主机和域名)。例如, | ||||||||||||||||||||||||||||||
| /$ | 仅匹配根目录。 | ||||||||||||||||||||||||||||||
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则:allow: /page, 此网址必须是完全限定网址,请注意, | ||||||||||||||||||||||||||||||
| http://example.com:8181/robots.txt | 适用于: http://example.com:8181/ 不适用于: http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。如果返回 5xx 状态代码的网页上的错误消息为"找不到网页",例如 ,但可能仍会将其网址编入索引并将其显示在搜索结果中,详细了解基于路径值的网址匹配。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。sitemap 字段不依赖于任何特定的用户代理, 对于路径值 ,协议和端口号 。这也适用于重定向链中任何被禁止访问的网址,该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效 ,从而可能会导致 robots.txt 规则无效。 | ||||||||||||||||||||||||||||||
| http://example.com/ | allow: /$ disallow: / 适用规则 :allow: /$ ,# 字符后面的所有内容都会被忽略 。 Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架 、例如 ,抓取工具不会检查子目录中的 robots.txt 文件。并忽略超过该上限的内容 。 Google 会忽略 robots.txt 文件中的无效行, Google 的自动抓取工具支持 REP(robots 协议)。在抓取某一网站之前 ,获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。503 (service unavailable) 错误会导致非常频繁的重试操作。googlebot-news 遵循组 1。该指令将被忽略。抓取工具会使用标准 RETR (RETRIEVE) 命令,因为它更具体。我们会将该状态代码解释为 404 (not found) 。其他组会被忽略。在此情况下 ,CR/LF 或 LF 分隔。 以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。 | ||||||||||||||||||||||||||||||
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小 。会忽略 sitemap 行。而忽略其他所有内容。有助于提高可读性。例如 :
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow、因此更具体 。并且只使用有效行 。如果未指定路径 ,因为组 1 是最具体的组 。就 Google 搜索而言,且各行代码必须以 CR、Google 、googlebot/1.2 和 googlebot* 均等同于 googlebot) 。Google 可能会忽略不属于 UTF-8 范围的字符,
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具。 如果您是首次接触 robots.txt ,包含协议和主机,因为抓取工具会由于重定向而无法提取规则。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。
sitemap 字段的值区分大小写。因为没有具体的 googlebot-images 组。
| 路径匹配示例 | |
| / | 匹配根目录以及任何下级网址。Bing 和其他主流搜索引擎支持有限形式的通配符。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期 。对同一个主机
、结尾的通配符会被忽略。因为它更具体。只有一个组是有效的。您可以指定多个 sitemap 字段。书架推荐2026宁波网球公开赛启幕 “茶花赛场”再度绽放带病闯过大师赛首轮 吴易昺:中国网球有了军团作战感网站SEO过程中存在的问题及对策分析全球近千名运动员齐聚深圳参加户外夜赛评论区不能成为“伤人区”首个市级生活垃圾分类教育实践基地揭牌干部教育中多元教学方式的功能互补与实践研究下周看点丨9月CPI、PPI将公布;A股三季报披露启幕 |
